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Introduction to HiJaak Browser

HiJaak Browser is the central product in the HiJaak Graphics Suite. From Browser, you can launch the 
other applications in the Suite and then use their editing and converting capabilities on a selected file. 
You can use HiJaak Browser in the following ways:

- Catalog files in a database Index file
- View file
- Search for files
- Create Custom Collections of files
- Create Directory based collections of files
- Print paper catalogs of files
- Convert a file from one graphics format to another
- Launch any Windows application

CATALOGING FILES
You can use HiJaak Browser to catalog all your files in an Index, allowing for full-fledged file 
management. HiJaak Browser automatically displays all directories and files it finds as thumbnails. You 
can also configure HiJaak Browser to update the Index automatically, at your convenience. To learn more 
about cataloging files, click on one of the following:
How to Organize and Catalog Files
How to Configure HiJaak Browser to Update the Index Automatically

VIEWING FILES
You can use HiJaak Browser to view images that are stored in any of the source formats supported by 
HiJaak Graphics Suite. You can also use it to open any file in a format associated with a Windows 
application. To learn more about viewing files, click on the following:
How to View a File

SEARCHING FOR FILES:
Using HiJaak Browser, you can search for any file by defining search rules based on available criteria. 
You can save the results of the search with or without search rules attached. HiJaak Browser allows you 
to search on the following criteria:

- File Name
- Location
- Date
- File Size
- Attributes
- Keywords

To learn more about searching for files, click on the following:
How to Search for Files

CREATING COLLECTIONS
You can create customized Collections to organize files in the way that makes the most sense to you: by 
format, project or content. You can keep just one copy of a file, yet still maintain references to it from 
several collections. To learn how to create a Collection, click on the following:
Create Collection

CREATING DIRECTORIES
You can create file based collections called Directories. A Directory contains thumbnails that represent the
contents of a floppy, hard, CD-ROM or network drive, or any other type of removable media. When you 
create a Directory in HiJaak Browser, you also create a DOS directory. To learn how to create a Directory, 
click on the following:
Create Directory

PRINTING CATALOGS OF FILES



HiJaak Browser allows you to print thumbnails of files, giving you a paper catalog of all your graphics files.
To learn more about printing in HiJaak Browser, click on the following:
How to Print

LAUNCHING APPLICATIONS
HiJaak Browser contains an Application bar to which you can add any application available to you. You 
can start a program by clicking on the application button or dragging a thumbnail representing a file you 
want to import or edit onto the application button. To learn more about launching applications, click on the 
following:
How to Launch Applications



Technical Support

If you are experiencing problems or getting unexpected results using HiJaak Browser, the 
Troubleshooting, Tips and Tricks help might help you find a solution. To get help, click on the following:
Troubleshooting HiJaak Browser

If you encounter problems you are unable to solve through the use of online Help or the Troubleshooting 
Help file, check the card at the beginning of the Getting Started With HiJaak Graphics Suite manual for 
information on obtaining technical support.
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Alphabetical Index A-F
A
Add Application
Adding Files to the Index
Application Bar, Setting Up
Application Bar, Using
Application Launching
Arranging Thumbnails
Associate Application
Associate Extension
Associations
Attributes, Properties dialog box
Attributes, Searching on
Auto Update

B
Building Collections
Button Bar Setup
By File Type

C
Caption, Displaying
Caption, Properties
Cataloging Files
Change Icon
Changing the View
Changing the View of an Image
Collections, Creating
Collections, Inserting
Confirmations
Copy
Create Collection
Create Directory
Create Search
Creating Directories, Collections or Searches
Creating an Index

D
Date, Properties
Date, Searching on
Default Viewer
Delete
Deselect
Directories, Creating

E
Excluded Keywords

F
File, Print
File Properties
File, Rename
File, Search
File Name, Searching on



Format Associations
Format Extensions



Alphabetical Index G-O
H
HiJaak Draw, Launching
HiJaak Graphics Suite, Launching Applications
HiJaak Smuggler
HiJaak TouchUp

I
Importing Graphics
Index, Auto Update
Index, Merge
Index, New
Index, Open
Index, Update
Index Tree, Hiding
Insert

K
Keyword Options
Keywords, Properties dialog box
Keywords, Searching on

L
Launching Applications
Location, Searching on

M
Merge Index
Modify Search
Move

N
Name, Changing
Name, Displaying in Thumbnail Window
New dialog box
New Index
Notes, Properties dialog box

O
Open Files
Open Files, Application
Open Index
Options, Drag & Drop
Organizing files



Alphabetical Index P-Z
P
Path, Properties
Prepare File for...
Print
Properties

R
Reconnect
Removing Thumbnails
Rename
Running Applications
Running Searches

S
Save As
Save Settings on Exit
Search
Select
Selecting Thumbnails
Settings, Saving
Set up Application Bar
Set up Button bar
Setup, Changing
Size, Properties
Size, Searching on
Size, Thumbnail
Skip Update, Attributes
Smart Update
Smuggler
Sort By
Spacing Between Thumbnails
Split bar, Moving
Subcollections, Creating
Subdirectories, Creating

T
Temporary Search
Thumbnail Windows, Copying
Thumbnail Windows, Creating
Thumbnail Windows, Moving
Thumbnail Windows, Printing
Thumbnail Windows, Save As
Thumbnails, Arranging
Thumbnails, Changing view
Thumbnails, Copying
Thumbnails, Deleting
Thumbnails, Inserting
Thumbnails, Moving
Thumbnail Options
Thumbnails, Printing
Time, Properties
Tree, Hiding



U
Update
Update, Automatic

V
View, Changing
View Menu
Viewing Files
Viewing Files in Applications
Volume

Z
Zoom 1:1
Zoom In
Zoom Out



File menu



New
Allows you to create a new Directory, Collection or Search in the
Index.



Open
Opens the file, Directory, Collection or Search represented by 
the selected thumbnail.



Save
Saves the active Directory, Collection or Search.



Save As
Allows you to save a thumbnail window under another name or 
as a different type. For example, this command allows you to 
save the results of a search as either a Search or a Collection.



Rename
Allows you to change the name of a file, Directory, Collection or 
Search.



Move
Allows you to move thumbnails from one thumbnail window to 
another. You may be restricted as to which thumbnails you can 
move depending upon the type of windows with which you are 
working.



Copy
Allows you to copy thumbnails from one thumbnail window to 
another. You may be restricted as to which thumbnails you can 
copy depending upon the type of windows with which you are 
working.



Delete
Allows you to delete thumbnails from a thumbnail window. If the
thumbnail is part of a Directory, this command also allows you 
to delete the file represented by the thumbnail.



Convert
Allows you to convert the graphics file represented by the 
selected thumbnail to another graphics file format.



Properties
Allows you to view and modify the properties of the file 
represented by the selected thumbnail.



Run
Alllows you to run any Windows application.



Print
Allows you to print any file in the Index. This command launches
the application with which the file is associated, and that 
application prints the file.



Print Thumbnails
Allows you to print one or more thumbnails in the active 
thumbnail window. 



Create Directory
Allows you to create a new Directory window.



Create Collection
Allows you to create a new Collection window.



Exit
Closes HiJaak Browser.



Edit menu



Copy to Clipboard
Copies the selected file in a HiJaak-supported file format to the 
Windows Clipboard.    



Insert
Allows you to insert the thumbnail of a file, Collection or Search 
into the active Collection window.



Select
Allows you to select thumbnails by name or extension.



Deselect
Deselects all selected thumbnails.



Bookmark
Allows you to assign a bookmark to a Directory, Collection or Search. Bookmarks allow you 
to return to a window quickly from anywhere in the Index window. 



View menu



By File Type
Allows you to select which file types are displayed in the 
thumbnail window.



Sort By
Allows you to sort thumbnails in a window by name, caption, 
extension, date or size. It also allows you to sort them manually.



Tree
Displays the Tree representing the contents of the Index in the 
Index window.



Volume
Displays the active volume and path in the Index window.



Split
Allows you to move the bar that separates the Index tree from 
the thumbnail window to the left or right.



Thumbnail
Displays thumbnails of files in the thumbnail window.



Name
Displays file names in the thumbnail window.



Caption
Displays file captions in the thumbnail window.



File Details
Displays name, date and file size in the thumbnail window.



Refresh
Scans the active directory for new files and adds them to the 
active Directory.



Search menu



Create
Allows you to specify criteria to use in a new file search. 



Modify
Allows you to modify the criteria associated with an existing 
Search.



Index menu



New Index
Allows you to create a new Index file. When a new Index is 
created, the current Index window closes. Note that a new Index
file does not contain any file information until you add files to it.



Open Index
Allows you to open an Index file. Only one Index can be open at 
a time.



Rename Index
Allows you to change the file name of the current Index.



Update
Updates the selected thumbnail or thumbnails and adds any 
new information to the Index.



Auto Update
Allows you to set up HiJaak Browser to update the Index file 
automatically.



Smart Update
Controls whether HiJaak Browser checks the file date and time 
when updating a thumbnail. When Smart Update is selected, 
HiJaak Browser will not update a thumbnail unless the date and 
time on the file have changed since the last update. When 
Smart Update is deselected, HiJaak Browser will perform an 
update, regardless of the time and date on the file. By default, 
this option is selected.



Merge Index
Allows you to merge the contents of one Index with the current 
Index. Note that the Index you are merging doesn't change; 
only the current Index changes.



Reconnect
Allows you to change the file path to which thumbnails point. 
This process is necessary if you move updated files using a 
program other than HiJaak Browser.



Setup menu



Thumbnail Options
Allows you to change the default settings for creating and 
displaying thumbnails. 



Keyword Options
Allows you to build a list of words that will be ignored when 
searching through notes. This is useful for eliminating common 
words from your Index and making searches faster.



Default Viewer
Allows you to select the default application in which images are 
opened.



Button Bar
Allows you to select which buttons appear in the HiJaak Browser
Button bar.



Application Bar
Allows you to select applications to appear in the HiJaak 
Browser Application bar.



Confirmations
Allows you to specify whether confirmation messages are given 
on selected file operations.



Associate Application
Allows you to associate any file extension with a given 
application.



Associate Format
Allows you to change which extension HiJaak associates with a 
particular format or add extensions to HiJaak. It also allows you 
to associate a file type with HiJaak PRO in the Windows File 
Manager.



Save Settings on Exit
Allows you to save the appearance of the windows upon exiting 
HiJaak Browser.



Window menu



New Window
Creates a clone of the active Index window.



Tile Horizontally
Arranges open windows side by side.



Tile Vertically
Arranges open windows from top to bottom.



Cascade
Arranges open windows by overlapping them so that the title 
bar of each window is visible.



Arrange Icons
Arranges thumbnails in the active window so there is equal 
space between each one.



Close
Closes the active Index or image window.



Close All
Closes all open Index or image windows with the exception of 
the first Index window that was opened.



Glossary
A-I K-Z

Aspect Ratio
Associate
Attributes
Automatic Update

Bitmap

Caption
Class
Collection
Criteria

Default Viewer
Directory
Thumbnail window
Drag & Drop

Extension

Folder File
Format

Graphics File
Grayscale

Hotkeys

Idle Time
Index
Index Tree
Index Window

Keywords

Metafile
Minimum Separation
Multimedia

Nested
Nodes
Notes

Objects
Options, Processing

Pixel
Properties

Raster
Resolution

Search Criteria
Split Bar
Subcollection

Thumbnail
Tree, Index

Update

Vector



Aspect Ratio
The height-to-width proportion of an image.



Associate
The process of assigning a file extension to an application. 
When an extension is assigned to an application, files with that 
extension will automatically open in that application when the 
application is launched from HiJaak Browser.



Attributes
Properties of a file. HiJaak Browser automatically extracts the 
following attributes: archive, class, colors (raster, vector or 
metafile), grayscale (raster, vector or metafile), height (raster 
only), hidden, pages (raster, vector or metafile), read only, 
system, type and width (raster only).



Automatic Update
An option that updates the Index while the computer is not busy
with other tasks.



Bitmap
A rectangular array of pixels arranged to make a picture.



Caption
Text that appears beneath a thumbnail, usually giving some 
information about the file that the thumbnail represents. The 
default caption is the name of the file; however, you can define 
captions using the Properties dialog box.



Class
The category into which a graphics file fits. Classes include 
raster, vector and metafile.



Collection
A type of thumbnail window that can contain thumbnails of files,
subcollections or Searchs.



Criteria
In the Search dialog box, the characteristics of the file for which 
you want to search.



Default Viewer
The application that will open a file in the selected format. 
HiJaak Browser is the default viewer for most graphics formats.



Directory
A thumbnail window that represents the contents of a floppy 
disk, hard disk, CD-ROM or network drive. Thumbnails within a 
Directory are organized based on location and can represent 
files or subdirectories.



Thumbnail window
A window that displays thumbnails that are in a Directory, 
Collection or Search. It is located in the right side of the Index 
window. 



Drag & Drop
The process of moving an element from one part of the screen 
to another using the mouse. In HiJaak Browser, drag-and-drop 
can be used to open files in an application and to move and 
copy thumbnails between windows.



Extension
Letters added to the end of a file name to indicate the format of
a particular file. Extensions can be no more than 3 letters.



Folder File
The earlier version of the HiJaak Browser thumbnail windows. 
File Folders are HiJaak Browser 2.0 windows that contain 
thumbnails. There are 3 types of folder files: Directory, Custom 
and Mirror. Directory folders can contain thumbnails that 
represent the contents of a directory: compare with Directory. 
Custom folders contain any group of thumbnails that you select:
compare with Collection. Mirror folders can contain thumbnails 
that represent the contents of a read-only directory or 
removable media. Folder files always have e an FLD extension.



Format
The unique manner in which a file's information is organized. A 
file format is a set of rules that defines how information will be 
organized and where information will be placed within the file. 
Some common file formats are PCX, CGM and WMF.



Graphics File
A file that contains only visual graphics information. There are 3
classes of graphics files: raster, vector or metafile.



Grayscale
An image made of shades of gray in steps ranging from black to
white. A grayscaled image looks like a black and white 
photograph.



Hotkeys
Keys that are used to invoke an action. In HiJaak Browser, 
hotkeys are used to run Smuggler. They are also used to set up 
Smuggler to work with applications that it does not normally 
recognize.



Idle Time
The number of minutes that the computer must be inactive 
before an automatic update begins.



 Index
A file that contains all of the information about files organized 
with HiJaak Browser.



 Index Tree
A structure that shows the relationships among the different 
areas of the Index. It is located on the left side of the Index 
window.



Index Window
The window that shows the contents of the Index. A split bar 
divides the window into two parts: the index tree and the 
thumbnail window.



Keywords
Words that are part of the notes of a file. Keywords can be used 
as criteria for conducting a file search.



Metafile
A class of graphics file formats that combines properties of both
raster and vector graphics.



Minimum Separation
The minimum amount of space between thumbnails in the 
thumbnail window.



Multimedia
A class of files that contains such features as sound and 
animation in addition to text and graphics.



Nested
A thumbnail window that has been placed within another 
window. HiJaak Browser allows you to nest a Directory within a 
Directory; a Collection within a Collection; and a Search within a
Collection.



Nodes
Icons on the branches of the Index tree. Each icon represents a 
type of storage: Directory, Collection or Search.



Notes
Text that has been extracted from a file and added to the 
properties of the file. By default, HiJaak Browser extracts all text
from vector files. Notes can also be added to any file using the 
Properties dialog box.



Objects
The elements that compose a vector image. Objects include 
lines, circles, arcs, beziers and others.



Pixel
A combination of the words "picture" and "element." The 
smallest unit of a bitmapped image represented on an 
electronic display (monitor or television). In a printed image, 
this unit is called a "dot."



Options, Processing
Options that change the look of an image. Processing options 
are available when using Smuggler and copying files to the 
Clipboard.



Properties
Information about a file such as attributes, keywords and notes.



Raster
A class of graphics file formats in which images are created and 
organized using individual dots, called pixels, that are arranged 
in a rectangular array called a bitmap. Raster images are 
usually created by scanners, fax machines or paint software 
applications such as HiJaak Paint.



Resolution
The size of an image expressed in number of pixels wide by 
number of pixels high; or, a measure of how closely packed an 
images pixels should be displayed or printed, usually in dots per
inch.



Search Criteria
In the Search dialog box, the characteristics of the file for which 
you want to search.



Split Bar
The movable line that divides the Index window into two parts. 
On the left side of the split bar is the Index tree; on the right 
side is the thumbnail window.



Subcollection
A Collection nested within another Collection.



Thumbnail
A small-scale replica of a supported image that contains 
information about the file such as file name, location and size. 
Thumbnails of graphics files are bitmapped representations of 
the actual graphics file. Thumbnails of all other formats appear 
as icons of the application that created the files.



Update
An option that adds new files to the Index, records changes that
have been made to files that are already part of the Index, and 
changes the appearance of thumbnails to reflect changes that 
have been made to the files they represent. Update also 
extracts notes and attributes from the files each time the Index 
is updated.



Vector
A class of graphics files formats in which images are created 
and organized using drawing objects such as lines, circles and 
squares. Vector images are usually created by CAD, graphics or 
drawing software applications.
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How to View a File
1.      In the Index Tree, double-click on the name of the thumbnail window that contains the 

thumbnail of the file you want to open. The thumbnail window opens.
2.      Click on the thumbnail representing the file you want to open. For more information on 

selecting thumbnails, click on the following:
Selecting Thumbnails
3.      Pull down the File menu and click on Open (Alt+f, o). The file will open in the 

application with which it is associated. 

If you select a file associated with HiJaak Browser, the image will appear in a separate 
window. When you want to close this window, double-click on the control bar. For a list of 
graphics file formats viewable by HiJaak Browser, click on the following:
Formats Supported
If you select a file associated with another application, HiJaak Browser will run the 
application with which the extension is associated, and that application will open the file.
For example, if you select a file with a WRI extension, HiJaak Browser will run Windows 
Write and Write will open the selected file.

Shortcut: Double-click on the thumbnail of the file you want to open.

To learn more about viewing files and thumbnail windows, click on one of the following:
How to Change the View of an Image
How to Change the View of a Thumbnail window
How to View and Change Properties of a File



Selecting Thumbnails

Description and Use of This Procedure
To work with thumbnails in HiJaak Browser, you need to know how to select them. This 
procedure describes how to select one or more thumbnails in HiJaak Browser.

Select Thumbnails as Follows:
To select one thumbnail, position the cursor over the thumbnail that you want to select and 
click the mouse button once. The thumbnail becomes highlighted, indicating that it is 
selected.
To select a range of thumbnails, press the SHIFT key as you click on the first thumbnail and 
the last thumbnail that you want to select. 
To select multiple discontiguous thumbnails, press the CTRL key as you click on each of the 
thumbnails that you want to select.

You can also select thumbnails by name or extension. For more information, click on the 
following:
Select

To learn how to deselect thumbnails, click on the following:
Deselect



Select

How to Find This Dialog Box
Select Select from the Edit menu and you will see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to select a group of thumbnails by name or extension, using DOS 
wildcards. This is useful if, for example, you want to delete all the TMP files from a directory.

Select a Group of Thumbnails by Name or Extension as Follows:
1. Pull down the Edit menu and click on Select (Alt+e, s). You will see the Select dialog box.
2. In the Files area, click on the radio button beside the type of files that you want to select. 

Click on All Files to select all thumbnails in the active thumbnail window (Alt+a). Click on 
Viewable Files to select all thumbnails representing files that are associated with an 
application in Windows File Manager (Alt+v). Click on File Names to specify a group of 
thumbnails to select (Alt+f). If you select File Names, click on the File Names area, and 
using the DOS wildcards * ?, type the name of the files you want to select (Alt+n). For 
example, if you want to select all the TMP files in the current thumbnail window, type 
*.TMP.

3. Click on OK. The specified thumbnails are selected in the thumbnail window.

For information on how to deselect thumbnails, click on the following:
Deselect



Deselect

How to Find This Command:
This command appears in the Edit menu.

Description and Use of This Command
This command allows you to deselect specified thumbnails in the current thumbnail window.

Deselect Thumbnails as Follows:
1. Pull down the Edit menu and click on Deselect (Alt+e, d). You will see the Deselect 

dialog box.
2. In the Files area, click on the radio button beside the type of files that you want to 

deselect. Click on All Files to deselect all thumbnails in the active thumbnail window 
(Alt+a). Click on Viewable Files to deselect all thumbnails representing files that are 
associated with an application in Windows File Manager (Alt+v). Click on File Names to 
specify a group of thumbnails to deselect (Alt+f). If you select File Names, click on the 
File Names area, and using the DOS wildcards * ?, type the name of the files you want to
deselect (Alt+n). For example, if you want to deselect all the TMP files in the current 
thumbnail window, type *.TMP.

3. Click on OK. All thumbnails containing the text you specified are deselected in the current 
thumbnail window.

Shortcut: To deselect all thumbnails in the thumbnail window, click on the GoBack 
arrow.



How to Change the View of an Image

Once you have opened an image in HiJaak Browser, you can change the magnification of the
view. For more information, click on one of the following:

Zoom In--zooms in on part of the image
Zoom Out--zooms out to make the image smaller
Zoom 1:1--resets the image's scale factor back to 100%



Zoom In

How to Find This Command
Click on the Control bar of an open image in HiJaak Browser, and you will see this 
command.

Description and Use of This Command
This command allows you to magnify any portion of an open image.

Zoom In on an Image as Follows:
1. Click on the Control bar of the image on which you want to zoom (Alt+Spacebar). You will

see the image's System menu.
2. In the System menu, click on Zoom In (i). You will see a submenu with the items 2x, 4x 

and Custom.
3. Click on the zoom option you want to use. Each option is described below.

2x: This option makes the image twice as large. If you select it, you will see a 
predefined rectangle. Position the rectangle over the part of the image on which you 
want to zoom and click the mouse button.
4x: This option makes the image 4 times as large. If you select it, you will see a 
predefined rectangle. Position the rectangle over the part of the image on which you 
want to zoom and click the mouse button.
Custom: This option allows you to define an area on which to zoom. Place the cursor 
on the image, click the mouse button and drag to define a custom area on which to 
zoom.

Shortcut: To perform a custom zoom, place the cursor over the image, click the mouse 
button, and drag to define a rectangular area on which to zoom.



Zoom Out

How to Find This Command
Click on the Control bar of an open image in HiJaak Browser, and you will see this 
command.

Description and Use of This Command
This command allows you to make the image smaller.

Zoom Out on an Image as Follows:
1. Click on the Control bar of the image you want to make smaller (Alt+Spacebar). You will 

see the image's System menu.
2. In the System menu, click on Zoom Out (o). You will see a submenu with the items 2x, 

4x and Fit in Window.
3. Click on the zoom option you want to use. Each option is described below.

2x: This option makes the image half of its current size.
4x: This option makes the image a quarter of its current size. 
Fit in Window: This option makes the image fit in the available window space, while 
maintaining the aspect ratio.



Zoom 1:1

How to Find This Command
Click on the Control bar of an open image in HiJaak Browser, and you will see this 
command.

Description and Use of This Command
When you zoom in or out on an image, the scale factor changes. This command allows you 
to reset the scale factor to one (100%).

Reset the Scale Factor to 100% as Follows:
1. Click on the Control bar of the image whose scale factor you want to reset 

(Alt+Spacebar). You will see the image's System menu.
2. In the System menu, click on Zoom 1:1 (100%) (Alt+z).



How to Change the View of a Thumbnail window
The HiJaak Browser View menu allows you to change the view of the Index and thumbnail 
windows in several ways:

*    To hide or show the Index tree, click on Tree (Alt+v, e). 
*    To hide or show the volume and path control at the top of the Index window, click on 

Volume (Alt+v, v). 
*    To move the bar separating the Index tree from the thumbnail window, either click on the 

bar and drag it to a new location, or select Split from the View menu and use the arrow 
keys to move it to a new location (Alt+v, p, arrow). 

*  To display thumbnails in the thumbnail window, select Thumbnail (Alt+v, t). If you 
deselect the Thumbnail option, only file names will display in the thumbnail window. 

*    To display file names in addition to thumbnails, select Name (Alt +v, n). 
*    To display file size and date in addition to file name, select File Details (Alt+v, d). 
*    To display thumbnails of Directories in the thumbnail window, select Directories (Alt+v, 

i). 
*    To scan a directory for new files to add to an open Directory window, select Refresh 

(Alt+v, r).
Note that the caption of the selected thumbnail appears in the status bar.

HiJaak Browser also allows you to decrease the number of thumbnails displayed by selecting
which file types will appear in the thumbnail window. For more information, click on the 
following:
By File Type

You can also arrange thumbnails based on name, date, size or extension. For more 
information, click on the following:
Sort By



By File Type
How to Find This Dialog Box
Select By File Type from the View menu and you will see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to narrow down the number of thumbnails displayed by selecting 
which file types will appear in the thumbnail window.

Display Thumbnails by File Type as Follows:
1. Pull down the View menu and click on By File Type (Alt+v, b). You will see the By File 

Type dialog box.
2. In the Files area, click on the radio button beside the type of files you want to display. 

Select All Files to display thumbnails of all files in the active Directory, Collection or 
Search (a). 
Select Viewable Files to display thumbnails of files that are associated with an 
application through Windows File Manager (v). 
Select File Names to specify a group of thumbnails to display (f). If you select File 
Names, you will have to specify which files you want to view in the File Name area (n). 
For example, if you want to display thumbnails of executable files, click in the File Name 
field and type *.EXE.

3. Click on OK.



Sort By
How to Find This Dialog Box
Select Sort By from the View menu, you will see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to arrange thumbnails in a thumbnail window.

Sort Thumbnails in the Thumbnail window as Follows:
1. Pull down the View menu and click on Sort By (Alt+v, s). You will see the Sort By dialog 

box.
2. In the Sort By area, click on the option that best matches how you want to arrange 

thumbnails in the thumbnail window (Alt+s, arrow).
Manual -- select this option to sort thumbnails by dragging to a new location
Name -- select this option to sort thumbnails alphabetically by file name
Extension -- select this option to sort thumbnails alphabetically by file extension
Date -- select this option to sort thumbnails by date
Size -- select this option to sort thumbnails by file size

3. In the Direction area, click on either the Ascending or the Descending radio button 
(Alt+d, arrow). Ascending sorts text alphabetically from A to Z and dates numerically from
oldest to newest. Descending sorts text alphabetically from Z to A and dates numerically 
from newest to oldest.



How to View and Change the Properties of a File
HiJaak Browser allows you to view and modify properties of a selected file or files through 
the Properties dialog box. This dialog box has 3 folders with tab controls that allow you to 
change the contents of the dialog box and select the type of properties you want to see. 
Choose from the following tabs:

Attributes -- view and modify the attributes that are automatically extracted from a 
file
Notes -- modify, add or delete notes and keywords to a file
Keywords -- view the keywords on which you can search

Pull down the File menu and click on Properties (Alt+f, e) You will see the Properties 
dialog box. Click on the tab that displays those properties you want to view. Note that if you 
select more than one file, the first Properties dialog box you see reflects the first thumbnail 
you selected. After you click on OK, the Properties dialog box for the second thumbnail 
appears and so on. 

Shortcut: You can view properties of a file by clicking the secondary mouse button on a 
thumbnail.

Click on the type of Properties about which you want more information:
Attributes
Notes
Keywords



Attributes (Properties dialog box)
How to Find This Dialog Box
If you select Properties from the File menu, you will see this dialog box. 

Description and Use of This Dialog Box
The Attributes folder in the Properties dialog box displays date, time, file size, path and other
attributes associated with the selected thumbnail. It also allows you to change the caption of
the thumbnail.

To display or modify attributes of a file, click on the thumbnail of the file for which you want 
to view or change properties. Pull down the File Menu and click on Properties (Alt+f, e). 
You will see the Properties dialog box. Click on the Attributes tab at the top of the 
Properties dialog box. You will see the Attributes folder. By default, this is the selected 
folder. 
Click on the Attribute about which you want more information:

Caption
Date
Time
Size
File Path
Attribute and Value
Skip Update



Caption
This option allows you to add descriptive text for the thumbnail.
This is useful when file names don't give enough information 
about file content. The caption of the selected thumbnail 
appears in the status bar.
To change this text, click in the Caption area and type a new 
caption (Alt+c).



Date
This area indicates the date that the file represented by the 
selected thumbnail was last modified. It cannot be edited 
directly.



Time
This area indicates the time that the file represented by the 
selected thumbnail was last modified. It cannot be edited 
directly.



Size
This area indicates the size of the file represented by the 
selected thumbnail. It cannot be modified directly.



File Path
This area shows the drive and directory of the file represented 
by the selected thumbnail. If the selected thumbnail represents 
a Collection or Search, only the Collection or Search name is 
shown. This area cannot be modified directly.



Attribute and Value
This area displays attributes of the selected file. The following 
attributes are automatically extracted from a file when it is 
updated in the Index:

Archive--backup files
Class--raster, vector, metafile, application document
Colors--number of colors in image (raster, vector or 
metafile)
Grayscale--image composed of shades of gray rather 
than color (raster, vector or metafile)
Height--height of image in pixels (raster only)
Hidden--files that cannot be accessed
Pages--number of pages in image (raster, vector or 
metafile)
Read Only--files that cannot be changed
System--files that are part of the operating or control 
system
Type--file format 
Width--width of image in pixels (raster only)



Skip Update
This option indicates the update status of the selected 
thumbnail. If Skip Update is selected, the thumbnail will be 
excluded from automatic updates. This is useful if the file that 
the thumbnail represents is not compatible with HiJaak Browser 
or if it has problems updating. If this option is not selected, the 
thumbnail will be updated whenever an automatic or manual 
update is performed.
To exclude a file from automatic updates, select the Skip 
Update check box (Alt+u).



Notes (Properties dialog box)
How to Find This Dialog Box
If you select Properties from the File menu, and click on the Notes tab at the top of the 
Properties dialog box, you will see the Notes folder.

Description and Use of This Dialog Box
This dialog box allows you to attach notes to a file. You can categorize the notes under 
different titles.

Attach Notes to a File as Follows:
1. Click on the thumbnail of the file or files for which you want to view or change properties. 
2. Pull down the File Menu and click on Properties (Alt+f, e). You will see the Properties 

dialog box. Click on the Notes tab at the top of the Properties dialog box. You will see the 
Notes folder. 

3. To add a title, click in the Title area and type a descriptive title for the category of notes 
you want to create (Alt+t). 

4. Click in the Notes field and type all notes you want associated with the title (Alt+n). 
5. Click on Add (Alt+a). The title and notes you selected are attached to the file.
6. Repeat steps 3-5 to add more notes and titles. 
7. Select Skip Note Update to exclude the thumbnail from automatic notes updates 

(Alt+u). The thumbnail will still be updated when one is performed, but the notes 
associated with the thumbnail will not be.

8. When you have added all the notes and titles you want, click on OK. 



Keywords (Properties dialog box)

How to Find This Dialog Box
Select Properties from the File menu, and click on the Keywords tab at the top of the 
Properties dialog box, to see the Keywords folder.

Description and Use of This Dialog Box
This dialog box displays the keywords attached to a file. This is different from the Notes 
folder in that the Notes folder displays all notes attached to a file; the Keywords folder 
only displays those notes that significantly describe the file and can be searched on. Those 
words in the ignorable words list are not included in this keyword list. For more information 
on ignorable words, click on the following:
Keyword Options

View Keywords Attached to File as Follows:
1. Click on the thumbnail of the file or files for which you want to view properties. 
2. Pull down the File menu and click on Properties (Alt+f, e). You will see the Properties 

dialog box. Click on the Keywords tab. You will see the Keywords folder listing those 
words on which HiJaak Browser can search.

Click on the Keywords option about which you want more information:
Keywords
Skip Keyword Update



Keywords
This list contains all keywords on which you can search for the 
selected file. It does not contain the words you excluded from 
automatic updates in the Setup menu's Keywords Options 
dialog box. 



Skip Keyword Update
This option indicates the update status of the selected 
thumbnail. During updates, notes are extracted from a file and 
a keyword list is built. Select the Skip Keyword Update check 
box to prevent HiJaak Browser from extracting keywords from 
the selected file. This is useful if you want to delete 
automatically extracted notes from the Notes folder. If you 
delete automatically extracted notes but do not select this 
check box, the notes associated with a thumbnail will be added 
whenever an update is performed. To select this option, click on 
the Skip Keyword Update check box.



How to Organize and Catalog Files
HiJaak Browser is a graphical file manager: it creates thumbnails of your files and arranges 
those thumbnails by location into Directory windows. It also allows you to catalog your files 
into custom Collection and Search windows. All of this information is stored in the Index. The
main HiJaak Browser window represents your Index: there is a tree on the left representing 
all available files, Collections and Searches, and a thumbnail window on the right, containing
thumbnails in the active Directory, Collection or Search window. To see what files are in your 
Index, double-click on the In Index branch in the Index tree. For more information on adding 
files to the Index, click on the following:
How to Update the Index

A Directory window represents the contents of a floppy, hard, CD-ROM or network drive. Files
are cataloged by their location. The thumbnails in a Directory window correlate directly to 
the files or subdirectories in a directory. For information on creating a Directory window, click
on the following:
Create Directory

A Collection window can contain thumbnails that represent files, subcollections or Search 
windows. Collections allow you to catalog files in the way that makes the most sense to you: 
by format, project or content. This type of organization allows you to reference a single copy 
of a file from several places. This is useful for saving disk space and maintaining current 
files. For information on creating a Collection window, click on the following:
Create Collection

A Search window contains thumbnails that represent files found as the result of a search run 
from the Search menu. A Search window contains a link to the original criteria. This link 
updates the Search based on this criteria whenever you update. For more information on 
searching for files and creating Search windows, click on the following:
How to Search for Files

You can also save a Search as a Collection or a Search. For more information, click on the 
following:
Save As

In addition to thumbnails, Directories, Collections and Searches, HiJaak Browser stores a 
variety of information about your files: file name, location, size, creation date, class, file 
type, notes and attributes. All of this information is contained in a common database called 
an Index. For more information on adding information to the Index, click on the following:
How to Update the Index

HiJaak Browser also allows you to bookmark Directories, Collections and Searches so you can
return to quickly. For more information on how to define and retrieve bookmarks, click on the
following:
Bookmark



New
How to Find This Dialog Box
Select New from the File menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to create a new Directory, Collection or Search window.

Create a New Directory Collection or Search as Follows:
1. Pull down the File menu and select New (Alt+f, n). You will see the New dialog box.
2. Click on the radio button beside the type of thumbnail window you want to create: 

Directory (d), Collection (c) or Search (s). In the Tree area of the dialog box, the 
thumbnail window type you selected becomes highlighted.

3. In the Tree area, click where you want the Directory, Collection or Search to be placed 
(Alt+t, arrow, Enter). If you want to create a top level thumbnail window, click on the 
Directory, Collection or Search icon. If you want to create a subdirectory or collection, click
on the branch under which you want to create the new thumbnail window. For example, to
create a Directory in the root of the C:\ drive, you would click on the C:\ branch in the Tree.

4. Click in the Name field and type the name you want to give the new Directory, Collection 
or Search (Alt+n). Directory windows follow the same naming conventions as directories. 
You can name Searches and Collections anything not to exceed 16 characters.

5.      Click on OK. What you see next depends upon what you selected in step 2:
Directory--If you selected Directory, HiJaak Browser will create a subdirectory and a 
Directory window in the path you selected from the Tree.
Collection--If you selected Collection, you will see the Insert dialog box. This dialog 
box allows you to add thumbnails to the new Collection. For information on using this 
dialog box, click on the following:
Insert
Search--If you selected Search, you will see the Search dialog box. This dialog box 
allows you to set up criteria on which to run your search. For instructions on running 
a search, click on the following:
How to Search for Files



Create Directory
How to Find This Dialog Box
Select Create Directory from the File menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to create a new Directory window and a new directory.

Create a New Directory as Follows:
1. Pull down the File menu and click on Create Directory (Alt+f, i). You will see the Create

Directory dialog box.
2. In the Tree area, click where you want the Directory to be placed (Alt+t, arrow, Enter). If 

you want to create a top level Directory, click on the Directory icon. If you want to create 
a sub-directory, click on the Directory under which you want to create the subdirectory. 
For example, to create a Directory in the root of the C:\ drive, you would click on the C:\ 
branch in the Tree.

3. Click in the Name field and type the name you want to give the new Directory (Alt+n). 
Directory windows follow the same naming conventions as DOS directories. 

4. Click on OK. 



Create Collection
How to Find This Dialog Box
Select Create Collection from the File menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to create a new Collection.

Create a New Collection as Follows:
1. Pull down the File menu and click on Create Collection (Alt+f, l). You will see the 

Create Collection dialog box.
2. In the Tree area, click where you want the Collection to be placed (Alt+t, arrow, Enter). If 

you want to create a top level Collection, click on the Collection icon. If you want to create
a subcollection, click on the Collection under which you want to create the subcollection. 
For example, to create a Collection named PCX beneath your IMAGES Collection, you 
would click on the IMAGES Collection branch in the Tree.

3. Click in the Name field and type the name you want to give the new Collection (Alt+n). 
Collection names can be up to 16 characters. 

4. Click on OK. You will see the Insert dialog box which allows you to insert thumbnails 
representing files, Collections or Searches into the new Collection you created. For 
information on how to use this dialog box, click on the following:

Insert



Save As
How to Find This Dialog Box
Select Save As from the File menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to save a Directory, Collection or Search as another type.

Save a Window as Another Type as Follows:
1. Make sure the Collection, Directory or Search you want to save is active.
2. To save the thumbnail window as another type, such as saving a Search as a Collection, 

pull down the File menu and click on Save As (Alt+f, a). You will see the Save As dialog 
box.

3. In the Type area, click on the radio button beside the type in which you want to save the 
current thumbnail window . You can save a window as a Collection (c) or a Search (s).

4. In the Tree area of the dialog box, double-click on the type of window you selected in step
3 (Alt+t, arrow, Enter). For example, suppose you searched for all the PCX files on your C:\
drive, creating a Search window. You then wanted to save it as a subcollection of an 
Images Collection. In the Tree area, you would double-click on the Images Collection 
branch. 

5. Click in the Name area and type the name you want to give the window (Alt+n).
6. Click on OK. The thumbnail window is saved as the type you selected. You will see a 

branch representing the Directory, Collection or Search in the area of the Tree you 
selected.



Insert
How to Find This Dialog Box
A. If you select Insert from the Edit menu, you will see this dialog box.
B. After you click on OK in the Create Collection dialog box, you will see this dialog box.
C. If you select Collection in the New dialog box and click on OK, you will see this dialog 

box.

Description and Use of This Dialog Box
This dialog box allows you to build a Collection by inserting thumbnails representing files, 
Collections or Searches into a new or active Collection window.

Create a Directory, Collection or Search as Follows:
1. Make sure that the Collection into which you want to insert a thumbnail is active, or create

a new Collection. For more information on creating a new Collection, click on the following:
Create Collection
2. Pull down the Edit menu and click on Insert (Alt+e, i). You will see the Insert dialog box. 

If you are creating a new Collection, you will see this dialog box after clicking on OK in the
New dialog box.

3. In the Tree area of the dialog box, double-click on the Directory, Collection or Search that 
contains the thumbnail you want to insert into the Collection (Alt+t). Its contents appear 
in the thumbnail window.

4. Click on the thumbnail representing the file, Collection or Search that you want to insert. 
To select more than one file, press the CTRL key as you click on the thumbnails you want 
to insert.

WARNING: Do not create recursive subcollections. You will create a recursive 
subcollection if you insert Collection 2 into Collection 1, and then insert Collection 1 
into Collection 2. HiJaak Browser does not support this structure and will GPF.

5. Click on OK to insert the thumbnail.



How to Print Files and Thumbnails
HiJaak Browser allows you to print files and thumbnails. You can print any file that is 
associated with an application in Windows File Manager. You can print any thumbnail or 
group of thumbnails in a thumbnail window. HiJaak Browser will print the thumbnails as they 
appear in the active window. For example, if you are viewing the thumbnail, file name and 
file details, all of this information will print.

Print Files as Follows:
1. Select the thumbnail that represents the file you want to print.
2. Pull down the File menu and select Print (Alt+f, p). The default editor for the file 

extension of the selected file starts up with its Print dialog box open. Note that for many 
graphics files, HiJaak Browser is the associated editor; HiJaak Browser will print the file.

3. Fill in the Print dialog box and click on OK. For more information on the Print dialog box, 
see the default editor's documentation.

Print Thumbnails as Follows:
1. Make sure the Directory, Collection or Search containing the thumbnails you want to print 

is on the screen and active. If you want to print only some of the thumbnails, press the 
CTRL key and click on the thumbnails you want to print.

2. Pull down the File menu and click on Print Thumbnails (Alt+f, t). You will see the Print 
Thumbnails dialog box. Notice the Page Sample area. This area shows how the 
thumbnails will fit on the printed page. 

3. In the Printer area, make sure the correct printer is selected. To select another printer, 
click on the Setup button (Alt+s). You will see the Setup Printer dialog box. Select the 
printer you want to use. Click on OK.

4. In the Layout area, click on the option that best represents how you want the thumbnail 
laid out on the printed page (Alt+l, arrow).

5. [OPTIONAL] To print a page number on the top of each page, click on the Page Number 
check box (Alt+n).

6. [OPTIONAL] To print the name of the Directory, Collection or Search on the top of each 
page, click on the Title check box (Alt+t).

7. Click on OK.



How to Perform Basic File Operations
You can perform the following basic file operations on HiJaak Browser Directories, 
Collections, Searches and thumbnails:

Rename
Move
Copy
Copy to Clipboard
Delete





Bookmark

How to Find This Dialog Box
Select Bookmark from the Edit menu, and you will see this dialog box.

Description and Use of This Dialog Box
You can attach a bookmark to a Directory, Collection or Search, allowing you to return to that
window quickly from anywhere in the Index window. The Bookmark dialog box allows you to 
define bookmarks for a Directory, Collection or Search. It also allows you to return to those 
windows you have bookmarked. You can have up to ten bookmarks.

Assign a Bookmark to the Active Window as Follows:
1. Open the Directory, Collection or Search that you want to bookmark.
2. Pull down the Edit menu and click Bookmark (Alt+e, b). You will see the Bookmark 

dialog box. This dialog box contains a list of available bookmark numbers CTRL+0 
through CTRL+9. These are the numbers that you can assign to the active window.

3. In this list, click on the bookmark number you want to assign to the active window. If you 
click on a number that is already used, the current path will be overwritten with the path 
to the selected window.

3. Click on the Add button (Alt+a). Whenever you press the CTRL+number key combination 
you assigned, HiJaak Browser will open that Directory, Collection or Search.
Shortcut: Open the Directory, Collection or Search that you want to bookmark. Press 
CTRL+SHIFT+number (0-9). 

Use Bookmarks to Go To a Window as Follows:
1. Pull down the Edit menu and select Bookmark (Alt+e, b). You will see the Bookmark 

dialog box with a list of all assigned bookmarks. 
2. In the list, click on the bookmark number attached to the window you want to go to.
3. Click on the Go To button.

Shortcut: Press CTRL+number (0-9) For example, if bookmark 3 is attached to the 
INSET dierctory, you can press CTRL+3 to return to the INSET directory from 
anywhere in the Index.



Rename
How to Find This Dialog Box
Select Rename from the File menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to change the name of a file, or a Directory, Collection or Search 
window.

Rename a File, Directory, Collection or Search as Follows:
1. Click on the thumbnail of the file, Directory, Collection or Search that you want to rename.

If you do not select a thumbnail, the active Collection, Directory or Search is selected by 
default.

2. Pull down the File menu and click on Rename (Alt+f, r). You will see the Rename dialog 
box.

3. In the From area, you will see the current name of the selected thumbnail.
4. Click in the To area (Alt+t). Type the new name you want to give the selected thumbnail. 
5. Click on OK.



Move
How to Find This Dialog Box
Select Move from the File menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to move a thumbnail from one thumbnail window to another. Note
that you cannot move a thumbnail from a Directory to a Collection. Collection windows 
contain only references to files; Directory windows contain the files themselves. This means 
that moving a thumbnail from a Directory to a Collection would delete the original file. Also, 
you cannot move any thumbnails into a Search window. Searches contain search rules, and 
any move into a Search window would conflict with these rules.

Move a Thumbnail Between Windows as Follows:
1. Click on the thumbnail that you want to move.
2. Pull down the File menu and click on Move (Alt+f, m). You will see the Move dialog box.
3. In the From area, you will see the path of the thumbnail you selected. 
4. Click in the To area (Alt+t). Type the full path to where you want to move the thumbnail. 

You can also use the Tree to build a path by clicking on the Directory, Collection or Search
and their subwindows in the path.

5. Click on OK.

Shortcut: Make sure the thumbnail window you are moving the thumbnail from and 
the window you are moving it to are open. (To open two windows, pull down the 
Window menu and select New Window (Alt+w, n).)    Click on the thumbnail you 
want to move and hold the mouse button down. Drag the thumbnail to the window to
which you want to move the thumbnail and release the mouse button.



Copy
How to Find This Dialog Box
Select Copy from the File menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to copy a thumbnail from one window to another. Note that you 
cannot copy thumbnails into a Search window. Searches contain search rules, and any move 
into a Search window would conflict with these rules.

Copy a Directory. Collection, Search or File as Follows:
1. Click on the thumbnail that you want to copy.
2. Pull down the File menu and click on Copy (Alt+f, c). You will see the Copy dialog box.
3. In the From area, you will see the path of the thumbnail you selected.
4. Click in the To area (Alt+t). Type the full path to where you want to copy the thumbnail. 

You can also use the Tree to build a path by clicking on the Directory, Collection or Search 
and its sub-windows in the path. 

5. Click on OK.

Shortcut: Make sure the thumbnail window you are copying the thumbnail from and 
the window you are copying it to are open. (To open two window, pull down the 
Window menu and select New Window (Alt+w, n). Click on the thumbnail you want
to move and hold the mouse button down. Press the CTRL key. Drag the thumbnail to 
the thumbnail window into which you want to place a copy of the thumbnail and 
release the mouse button.



Copy to Clipboard
Description and Use of This Command
This command allows you to copy most images to the Windows Clipboard. If a files is in a 
HiJaak-supported source format, you can copy that file to the Clipboard. For a list of HiJaak-
supported formats, click on the following:
Formats Supported

Copy a File to the Windows Clipboard as Follows:
1. Click on the thumbnail representing the file you want to copy to the Windows Clipboard.
2. Pull down the Edit menu and click on Copy to Clipboard (Alt+e, c). A copy of the file 

you selected is placed in the Windows Clipboard. 



Delete
How to Find This Dialog Box
Select Delete from the File menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to delete thumbnails of files, or Directories, Collections or 
Searches.

Delete a Thumbnail as Follows:
1. Click on the thumbnail or thumbnails you want to delete.
2. Pull down the File menu and click on Delete (Alt+f, d). You will see the Delete dialog 

box.
3. To delete both the thumbnail and the file it represents, click on Yes for the selected 

thumbnail (Alt+y) or Yes to All for all selected thumbnails (Alt+a). Unless you select Yes 
to All, you will see the Delete dialog box for each thumbnail you selected.

4. To delete the thumbnail but not the file, click on No for the selected thumbnail (Alt+n) or 
No to All (Alt+o) for all selected thumbnails. Note that if you are deleting from a 
Directory window and you select No or No to All, the thumbnails will reappear in the 
Directory window because the files themselves still exist.



What is the "Index"?

The HiJaak Browser Index contains information about all the files you catalog with HiJaak 
Browser. This information includes a file's name, location, size, date, attributes and 
keywords; information that is necessary when you are trying to organize a large number of 
files. 
Although HiJaak Browser will display all files on your system, the only files that are actually 
in the Index are those that you add by "updating." For more information on updating the 
Index, click on the following:
How to Update the Index

There are two ways to see what files are in your Index. 
First, look at the Index tree in the HiJaak Browser Main window. Notice that most folders 
in the Index tree are yellow, but some are cyan. The cyan color tells you that at least some of the 
files in the those directories are in the HiJaak Browser Index. 
To see exactly what files are in your Index, double-click on the In Index branch in the 
Index tree. The In Index section of the tree contains thumbnails of only those files 
that have been updated. But it contains all files that have been updated, even those 
that may be located on removable media that is not in the drive. It is in the In Index 
section of the tree that you would look for indexed images located on CD-ROM, 
network drive or other removable media.

For information on managing the Index, click on one of the following:
How to Create an Index
How to Open an Index
How to Rename an Index
How to Configure HiJaak Browser to Update the Index Automatically
How to Merge Two Indexes
How to Reconnect Thumbnails to Files



How to Update the Index
Description and Use of This Procedure
HiJaak Browser allows you to update your Index by file, by directory or by lists of directories. 
When a file is updated, several things will happen. If the file was not originally part of the 
Index, it will be added to the Index. If it is part of the Index, but is out of date, then changes 
to the file such as date, size, location and name will be recorded and will appear in the 
Properties dialog box when the file is selected. Also, changes to the appearance of a 
graphics file will be reflected in the thumbnail representing the file. 

By default, HiJaak Browser extracts all text from a file and adds it as Notes to the properties 
of the file. HiJaak Browser also extracts the file name, size, date, location and attributes from
the file.

All file information extracted during an update is added to the properties of each file. For 
more information on properties, click on the following:
Properties

Update a Thumbnail as Follows:
1. Click on the thumbnail representing the file you want to update.
2. Pull down the Index menu and select Update (Alt+i, u). For new files, HiJaak Browser 

creates a thumbnail and adds the file information to the Index. For files needing updating, 
HiJaak Browser updates the thumbnail and the properties of the file.

To learn how to configure HiJaak Browser to update the Index automatically, click on the 
following:
How to Configure HiJaak Browser to Update the Index Automatically

If you try to update a thumbnail that has already been updated, HiJaak Browser checks for 
any changes in the file. If it detects no changes, it does not update. To learn how to force 
HiJaak Browser to update a thumbnail, click on the following:
Smart Update



Smart Update

How to Find This Command
Pull down the Index menu and you will see this command.

Description and Use of This Command
If you try to update a thumbnail that is already part of the Index, by default, HiJaak Browser 
checks the date and time on the file. If the date and time have not changed, HiJaak Browser 
assumes that the file has not changed and does not update the thumbnail. This process is 
called Smart Update. If you want, you can force HiJaak Browser to update a thumbnail, 
regardless of the date and time on the file.

Set Smart Update as Follows:
To force HiJaak Browser to update all selected thumbnails, pull down the Index menu and 
click on Smart Update (Alt+i, s). The check mark beside the menu item disappears, 
indicating that Smart Update is disabled.



How to Create an Index
Description and Use of This Procedure
HiJaak Browser allows you to create multiple Indexes. This allows you to store private files in 
an Index on your hard drive and access shared files on a network.

Note that although you can create as many Indexes as you want, you can only have one 
Index open at a time. When you open a particular Index, no other user on the network can 
access it until you close it.

Create a New Index as Follows:
1. Pull down the Index menu and select New Index (Alt+i, n) You will see the New Index 

dialog box.
2. Pull down the Drives drop-down list and click on the drive on which you want to save the 

Index file (Alt+v, arrow, Enter).
3. In the Directories list box, double-click on the subdirectory in which you want to save the

Index file (Alt+d, arrow, Enter).
4. In the File Name area, type the name that you want to give the Index file (Alt+n). 
5. Click on OK. Note that no files will be included in this Index until you update the file. For 

more information on updating, click on the following:
How to Update the Index



How to Open an Index
Note: You can only have one Index open at a time. When you open a particular 
Index, no other user on the network can access it until you close it.

1. Pull down the Index menu and select Open Index (Alt+i, o). You will see the Open Index
dialog box.

2. Pull down the Drives drop-down list and click on the drive that contains the Index file you 
want to open (Alt+v, arrow, Enter).

3. In the Directories list box, double-click on the subdirectory where the Index file is 
located(Alt+d, arrow, Enter). Note that you must have read rights to this directory.

4. In the File Name area, type the name of the Index file you want to open (Alt+n).
5. Click on OK. The Index that was open closes, and the Index you just selected opens in the 

HiJaak Browser Main window.



How to Rename an Index

Rename An Index as Follows:
1. Pull down the Index menu and click on Rename Index (Alt+i, r). You will see the 

Rename Index dialog box.
2. The Current Index Name field contains the current name of the active Index. To change 

this name, click in the New Index Name area and type the name you want to give the 
Index (Alt+n). 

3. Click on OK to change the name of the active Index.



How to Configure HiJaak Browser to Update the Index Automatically
Description and Use of This Procedure
You can configure HiJaak Browser to update the Index automatically during your computer's 
idle time or at a time you schedule. The benefit to configuring HiJaak Browser to update the 
Index automatically is that you will have a consistently maintained and updated Index. You 
won't have to worry that the thumbnails are out of date. Before HiJaak Browser can update 
your Index automatically, you must configure Auto Update options. 

Configure Auto Update as Follows:
1. Pull down the Index menu and select Auto Update (Alt+i, a). You will see the Auto 

Update dialog box.
2. In the Tree area, click on the Directory, Collection or Search you want to add to the 

Update List (Alt+t, arrow). 
3. Click on the Add button (Alt+a). The name you selected appears in the Update List.
4. Repeat steps 2 and 3 for every Directory, Collection and Search you want HiJaak Browser 

to automatically update.
5. If you want to add all your available drives to the Update List, click on the Add All 

button (Alt+d).
6. If a Directory, Collection or Search appears in the Update List, but you don't want it 

updated, you can exclude it from automatic updates. Click on the name in the Update 
List and click on the Remove button (Alt+u, arrow, Alt+r).

7. If you want the subdocuments of a Directory or Collection in the Update List to be 
updated automatically, click on the Sub Documents check box beside the thumbnail 
window name in the Update List (Alt+u, arrow, spacebar)

8. After you select the Directories, Collections and Searches you want to update, you must 
select a time at which you want HiJaak Browser to update. You can either schedule a time,
set an idle time, or do both. 

        To schedule a time, click in the Scheduled Time area and type the time at which you 
want HiJaak Browser to begin the automatic update (Alt+s). Use the time format specified 
in your Windows International Settings. 

        To set an idle time, click in the Idle Time area and type the number of minutes you want
your computer to remain idle before HiJaak Browser begins an update (Alt+i). 

9. To begin updating immediately, click on the Start button (Enter). To wait until the 
specified update times, click on the Close button (Esc). 

If you try to update a thumbnail that has already been updated, HiJaak Browser checks for 
any changes in the file. If it detects no changes, it does not update. To learn how to force 
HiJaak Browser to update a thumbnail, click on the following:
Smart Update



How to Merge Two Indexes

Description and Use of This Procedure
HiJaak Browser allows you to merge an Index into the current Index. When you merge one 
Index into another, the Index that is being merged does not change. It is as if the 
information in that Index is being copied rather than moved. If the Indexes have thumbnails, 
attributes or keywords associated with files common to both, the information with the most 
recent date is used. If there are user defined Collections, Searches or notes with the same 
name, a :2 is appended to the name of the Collections, Searches or Notes from the Index 
that is being merged.

Merge Two Indexes as Follows:
1. With one of the Indexes that you want to merge open, pull down the Index menu and click

on Merge Index (Alt+i, m). You will see the Merge Index dialog box.
2. Pull down the Drives drop-down list and click on the drive that contains the Index file you 

want to merge (Alt+v, arrow).
3. In the Directories list box, double-click on the subdirectory where the Index file is located

(Alt+d). Note that you must have read rights to this directory.
4. In the File Name area, type the name of the Index file you want to merge (Alt+n).
5. Click on OK. The contents of the Index that you selected are merged into the current 

Index.



How to Reconnect Thumbnails to Files

Description and Use of This Procedure
When you update an Index, the thumbnails that are created point to the files that they 
represent. There may be times when HiJaak Browser loses this connection between 
thumbnails and files. For example, if a file is moved using a program other than HiJaak 
Browser, then the thumbnail will point to a location in which the file does not exist. HiJaak 
Browser represents this condition by placing an X through the thumbnail. To fix this problem,
you must reconnect the thumbnails to the files.

Reconnect Thumbnails to Files as Follows:
1. In the In Index section of the Index Tree, select the thumbnails that represent the files 

that have been moved.
2. Pull down the Index menu and click on Reconnect (Alt+i, r). You will see the Reconnect 

dialog box.
3. Click in the Name area and type the full path to the files you want to reconnect (Alt+n). 

You can also use the Tree to build a path by clicking on the Directories and subdirectories 
in the path (Alt+t, arrow, Enter). As you select Directories from the tree, they will appear 
in the Name area. 

4. Click on OK. You will receive a message indicating how many thumbnails have been 
reconnected to the files. Note that if you don't specify the correct path in the Reconnect 
dialog box, the thumbnails will not be reconnected. 

Note on Reconnecting Entire Directories: HiJaak Browser allows you to reconnect
an entire directory by selecting the directory thumbnail, as long as the original 
directory and the target directory have the same name. If the original directory and 
the target directory have different names, then you can select all of the thumbnails in
the original directory, and reconnect using the procedure above.
For example: Suppose that you created and updated a clip art directory on your 
hard drive named C:\CLIPART. Later, you decide to free hard disk space by moving the
clip art to a network directory. 
If you move the files to the directory G:\CLIPART, you must select the CLIPART 
Directory thumbnail in the In Index area of the tree and perform steps 2-4 of the 
procedure above.
If you move them to a directory with another name, such as G:\IMAGES, then you 
must open the CLIPART Directory thumbnail window in the In Index area of the tree. 
Hold down the Shift key and click on the first and the last thumbnail in the CLIPART 
Directory window. All of the thumbnails will be selected. Then, follow steps 2-4 of the 
procedure above to reconnect the thumbnails to the files in G:\IMAGES.



How to Search for Files
Description and Use of This Procedure
HiJaak Browser allows you to search for any file or group of files in the Index. A search report
is generated and the files that are found are placed in a thumbnail window. The search 
report is represented as the Temporary Search node in the Index Tree. This window can be 
saved as either a Search with search criteria attached, or as a Collection with only 
thumbnails attached. 
To save the Temporary Search as a Search or a Collection, pull down the File menu and click 
on Save As. For more information on how to use the Save As dialog box, click on the 
following:
Save As

IMPORTANT! If you don't save a Temporary Search as a Search or Collection before 
you run another Search, you will lose the initial search report. If the search results are
important, make sure you save them. 

Search for Files as Follows:
To run a search, pull down the Search menu and click on Create (Alt+s, c). You will see the 
Search dialog box. The Search dialog box contains a number of criteria on which you can 
search. Specify the options on which you want to search and click on OK. Each option can be
selected only once.

TIP: By default, HiJaak Browser searches the Index for files adhering to the criteria 
you specify. If you want to search a drive that has not been indexed, click in the 
Location area and specify the drive you want to search. HiJaak Browser will then 
search the specified drive and all of its subdirectories for files that adhere to the 
other criteria you specify:

Click on the search option about which you want more information.
File Name -- finds files by full or partial file name 
Location -- finds files by drive and directory 
Keywords -- finds files by one or more keywords attached to the files
Size -- finds files by exact file size or a range of file sizes
Date -- finds files by exact date or a range of dates
Attributes -- finds files by one or more attributes, such as type, class and colors



File Name
Use this option to search for files that have a specific file name 
or that contain certain letters in the file name. The Match 
option must be used in conjunction with this option.
To find files by file name, type as much of the file name as you 
know into the File Name area (Alt+n). You can use the DOS 
wildcards * and ? to replace the part of the file name you do not
know. Once you type the file name, select the Match option.



Match
Use this option when searching for files by name. This option 
indicates where the specified letters are located in the file 
name.
To use this option, fill in the File Name area (Alt+n). Then, pull 
down the Match list and select where the text you entered in 
the File Name area should appear in the file name (Alt+m, 
arrow). You have a choice of the following: Starts With, Ends 
With, Contains, and Exact Match. Exact Match is the default.



Location
Use this option to search for files on a specific drive or directory.
By default, HiJaak Browser searches all available drives and 
directories that are in the Index. This can be very time 
consuming. It is suggested that you enter a path into this field 
to narrow the search.
To search a specific location, click in the Location area and 
type the full path where you want to search (Alt+l). If you are 
not sure of the complete path, click on the Browse button 
(Alt+b). You will see the Browse dialog box. Select the path and
click on OK. The path you selected appears in the Location 
area of the Search dialog box.



Browse

How to Find This Dialog Box
A. Click on the Browse button in the Create Search dialog box.
B. Click on the Browse button in the Associate Application dialog box.

Description and Use of This Dialog Box
This dialog box allows you to identify the full path you want to use in the Location area of the
Search dialog box. It is useful if you cannot remember this information. 

Browse for a File Path as Follows:
1.      In the Search dialog box, click on the Browse button (Alt+b). You will see the Browse 

dialog box.
2.     Click in the Name area and type the full path to the files you want to reconnect (Alt+n). 

You can also use the Tree to build a path by clicking on the Directories and subdirectories 
in the path (Alt+t, arrow, Enter). As you select Directories from the tree, they will appear 
in the name area. 

3.      Once you have built the complete path, click on OK. HiJaak Browser places the path you
selected into the Location area of the Search dialog box.



Keywords
Use this option to search for files that contain certain keywords 
in the notes attached to the file. Keywords are either 
automatically extracted from the file during auto update or 
manually defined in the Properties dialog box.
To search for files with certain keywords, click in the Keyword 
area and type the keywords (Alt+k). HiJaak Browser will search 
for files that contain every keyword you type, regardless of their
position or proximity in the notes.



Size
Use this option to search for files that are a specific size or that 
fit into a range of sizes. 
Click on the radio button beside the unit of measurement you 
want to use. You have the choice of Bytes, KB (Kilobytes) or 
MB (Megabytes).
To search for files that are a specific size, click in the first field in
the Size area and type that size. Then, click in the To field of 
the Size area and type that same size (Alt+s, Tab).
To search for files that fit into a range of sizes, click in the first 
field in the Size area and type the smallest size for which you 
want to search. Then, click in the To field of the Size area and 
type the largest size for which you want to search (Alt+s, Tab). 



Date
Use this option to search for files that were last modified on a 
specific date or within a range of dates. 
To search for files that were last modified on a specific date, 
click in the first field in the Date area and type the date for 
which you want to search. Then, click in the To field of the Date
area and type that same date (Alt+d, Tab).
To search for files that were modified during a range of dates, 
click in the first field in the Date area and type the earliest 
possible date for which you want to search. Then, click in the To
field of the Date area and type the latest possible date (Alt+d, 
Tab).



Attributes
Use this option to search for files that have certain attributes. 
You can search on any default or custom attribute. For more 
information on available attributes, click on the following:
Attributes

To use this option, pull down the Attribute list and select the 
attribute on which you want to search (Alt+a, arrow). Pull down 
the Relationship list and click on the operator that shows the 
relationship between the attribute and the value you will select 
(Alt+r, arrow). Pull down the Value list and type the value you 
want assigned to the attribute (Alt+v). 
For example, suppose you want to search for all files with 256 
colors. In the Attributes list, select Colors. In the Relationship 
list, select Equals. In the Value list, type 256. The equation 
becomes COLORS=256. HiJaak Browser will search for all files 
that have 256 colors.



How to Launch Applications
You can launch an application from HiJaak Browser in one of 4 ways:

*  Click on the button that represents the application in the Application bar.
*  Drag a thumbnail representing a file in a format associated with an application onto 

that application's button in the Application bar. The application will start up and open 
the file you selected.

*  Double-click on a thumbnail that is associated with the application you want to run. 
The application will start up and open the file you selected.

*  Pull down the File menu and click on Run. You will see the Run dialog box. Type the 
full path and file name of the application you want to run. Click on OK.

Launching Applications in HiJaak Graphics Suite
HiJaak Browser allows you to launch any of the applications in the HiJaak Graphics Suite: 
HiJaak PRO, Paint, HiJaak Smuggler or HiJaak Draw. This is useful if you want to browse or 
search for a file and then bring it into one of the Suite's editors. If the file you want to edit is 
in a format that HiJaak Browser supports, but the editor does not, then HiJaak Browser will 
prepare the file by converting the file into a format that the editor does support. For more 
information, click on the following:
Prepare File



Run
How to Find This Dialog Box
Pull down the File menu and click on Run, and you will see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to run any Windows application.

Run an Application as Follows:
1. Pull down the   F  ile menu and click on Run (Alt+f, r). You will see the Run dialog box.
2. Click in the Command Line field and type the full path and file name of the application 

you want to run. If you don't know the full path, click on the Browse button. You will see 
the Browse dialog box. Select the path to the application and click on OK.

3. Click on OK. The application you specified starts.



Prepare File
How to Find This Dialog Box
If you drag a thumbnail that is supported by HiJaak Browser, but not supported by Paint or 
HiJaak Draw to those icons in the Application Bar, you will see this dialog box.

Description and Use of This Dialog Box
This dialog box prepares files that are not readable by Paint or HiJaak Draw for those 
applications. This allows you to launch those applications from HiJaak Browser using any file 
that HiJaak Browser supports. The Prepare File dialog box allows you to select a format for 
the importing file and allows you to select the drive and directory where you want the 
converted file saved.

Prepare a File for Paint or HiJaak Draw as Follows:
1. Drag the thumbnail of a file in a HiJaak-supported format to either the Paint or HiJaak 

Draw icon in the Application bar. 
If the file is in a format that the target application supports, the application starts up and 
opens the file you selected. 
If the file is in a format that HiJaak Browser supports, but the target application does not, 
then you will see the Prepare File dialog box.

2. Select the drive and directory where you want HiJaak Browser to store the converted file it
prepares for use in the target application.

3. By default, HiJaak Browser selects the file type that should work best with the target 
application. If you want to change the file type, pull down the List Files of Type drop-
down list and select the format in which you want to open the file (Alt+t, arrow). 

4. Click in the File Name area and type the name you want to give the new file (Alt+n).
5. Click on OK. HiJaak Browser converts the file to the selected file type. Then Paint or HiJaak

Draw starts up and opens the file. Note that the original file you selected is not changed. 
Only the new converted file will show any changes you make.



How to Import Files
HiJaak Browser allows you to import files using drag-and-drop. You can drag a thumbnail and
drop it on an application that supports the format of the file represented by the thumbnail. 
The application opens the file. 

You can also import graphics into any application that supports pasting graphics through the 
Windows Clipboard by using Smuggler. For more information on Smuggler, click on the 
following:
HiJaak Smuggler

Import or Open a File Using Drag-and-Drop as Follows:
1. Open HiJaak Browser by double-clicking on its icon.
2. Open the Directory, collection or Search that contains the thumbnail of the file you want 

to import or open.
3. Click and hold the mouse button down on the thumbnail of the file. 
4. Drag the thumbnail to an open application and drop it there by releasing the mouse 

button. The application opens the file you selected. 

For example, you can open a PCX file in PC Paintbrush. Click on the thumbnail of the PCX 
file and drag it to the open PC Paintbrush application. Release the mouse button. The PCX 
image opens in the PC Paintbrush Main window.



How to Change the HiJaak Browser Setup
HiJaak Browser allows you to customize global settings using commands located in the 
Setup menu. Click on the command about which you want more information:

Thumbnail Options -- customizes how thumbnails are created and displayed
Keyword Options -- excludes common words from the Index keyword list
Default Viewer -- determines which application will open HiJaak-supported graphics formats
Button Bar -- sets up the buttons in the Button bar
Application Bar -- sets up and adds applications to the Application bar
Confirmations -- specifies whether confirmation messages are given on certain file 
operations
Associate Application--associates an application with a format extension
Associate Format--changes which file extension HiJaak Browser associates with a particular 
format. This option also allows you to associate a file type with HiJaak PRO in Windows File 
Manager
Save Settings on Exit -- controls how the HiJaak Browser Main window appears upon startup



Thumbnail Options
How to Find This Dialog Box
Select Thumbnail Options from the Setup menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to set up the size at which thumbnails are created and displayed. 
For best results, thumbnails should be created and displayed at the same size. This dialog 
allows you to determine the minimum amount of space that will separate the thumbnails.

Set up Thumbnail Options as Follows:
1. Pull down the Setup menu and click on Thumbnail Options (Alt+s, t). You will see the 

Thumbnail Options dialog box.
2. Click in the Minimum Separation area and type the least number of pixels you want 

separating the thumbnails (Alt+m). Note that space may vary depending upon the size 
and number of thumbnails displayed.

3. Pull down the Creation Size drop-down list and click on the size at which you want 
thumbnails created (Alt+c, arrow). You have the choice of Small (64x64), Medium 
(80x80) or Large (120x120). Small is the default.

4. Pull down the Viewing Size drop-down list and click on the size at which you want 
thumbnails displayed (Alt+v, arrow). You have the choice of Small (64x64), Medium 
(80x80) or Large (120x120). Small is the default.

5. Click on OK.



Keyword Options
How to Find This Dialog Box
Select Keyword Options from the Setup menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to configure HiJaak Browser to ignore selected words when it 
automatically extracts words from file. This helps keep Index size small and helps increase 
the speed of a search by excluding common words that appear in many files. Common 
words that may be excluded are "and," "a," "the," "is" and "it." There is no limit to the 
number of words you can exclude.

Exclude Words from Automatic Updates as Follows:
1. Pull down the Setup menu and click on Keyword Options (Alt+s, k). You will see the 

Keyword Options dialog box. 
2. Click in the Excluded Keywords list and type the word you want HiJaak Browser to 

ignore when automatically extracting text from files (Alt+e).
3. Click on the Add button (Alt+a). The word is added to the list.
4. Repeat steps 2 and 3 to add words.
5. To remove a word from the list, click on the word and click on the Remove button (Alt+r).
6. Click on OK.



Default Viewer
How to Find This Dialog Box
Select Default Viewer from the Setup menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to select the application that will display HiJaak-supported 
graphics files when you open them from HiJaak Browser.

Select a Default Viewer as Follows:
1. Pull down the Setup menu and click on Default Viewer (Alt+s, v). You will see the 

Default Viewer dialog box.
2. To display images in HiJaak Browser, click on the HiJaak Browser radio button (b). This is 

useful if you need to view many images quickly.
To display images in HiJaak PRO, click on the HiJaak PRO radio button (p). This is useful if 
you need to edit or convert images.
To display images in the application with which they are associated in Windows File 
Manager, click on the File Manager Association radio button (f). This option would, for 
example, open PCX files in PC Paintbrush. This is useful if you need to use the image's 
original editor.

3. Click on OK.



Button Bar
How to Find This Dialog Box
Select Button Bar from the Setup menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to configure the HiJaak Browser Button bar. You can select the 
types of buttons used, which buttons appear, and in what order they appear.

Set Up the Button Bar as Follows:
1. Pull down the Setup menu and click on Button Bar (Alt+s, b). You will see the Button 

Bar dialog box.
2. HiJaak Browser accommodates both large and small buttons. By default, large buttons are

used. To select the type of buttons you want to use, click on the Large (l) or Small (s) 
radio button in the Style area of the dialog box.

3. In the Available Icons area, click on the icon that you want to add to the Button bar 
(Alt+i, arrow). Click on the Add button (Alt+a). The button is added to the Icons in 
Button Bar list.

4. To change the order of the buttons in the Button bar, click on the button that you want to 
move in the Icons in Button Bar list (Alt+b, arrow). Click on the Move Up button to 
move the button up one item in the list (Alt+u). Click on the Move Down button to move 
the button down one item in the list (Alt+d). Continue clicking on Move Up and/or Move 
Down until the button is at the desired location in the Button bar.

5. To group similar buttons, click on the first icon you want to include in the group. Click on 
the Separator button (s). HiJaak Browser adds space before that button in the Button bar.

6. To remove a button or Separator from the Button bar, click on the button or Separator in 
the Icons in Button Bar list. Click on the Remove button (Alt+i, arrow, Alt+r).

7. If you don't want to display the Button bar, click on the Show Button Bar check box to 
deselect it (Alt+s).

8. Click on OK. The Button bar is modified to reflect the changes you have made.



Application Bar
How to Find This Dialog Box
Select Application Bar from the Setup menu to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to configure the HiJaak Browser Application bar. You can add 
application icons, remove them, change the order, change the icons representing 
applications, or hide the Application Bar altogether.

Set up the Application Bar as Follows:
1. Pull down the Setup menu and click on Application Bar (Alt+s, a). You will see the 

Application Bar dialog box.
2. To add an application, click on the Add button (Alt+a). You will see the Add Application 

dialog box. For information on using this dialog box, click on the following:
Add Application

3. To remove an application, click on the application icon and path in the Applications list. 
Click on the Remove button (Alt+p, arrow, Alt+r).

4. To change the icon representing an application, click on the application icon and path in 
the Applications list. Click on the Change Icon button (Alt+p, arrow, Alt+i). You will see 
the Change Icon dialog box. For more information on using this dialog box, click on the 
following:
Change Icon

5. To change the order of the buttons in the Application bar, click on the button that you 
want to move in the Applications list (Alt+p, arrow). Click on the Move Up button to 
move the button up one item in the list (Alt+u). Click on the Move Down button to move 
the button down one item in the list (Alt+d). Continue clicking on Move Up and/or Move 
Down until the button is at the desired location in the Application bar.

6. If you don't want to display the Application bar, click on the Show Application Bar check
box to deselect it (Alt+s).



Add Application
How to Find This Dialog Box
Click on the Add button in the Application Bar dialog box to see this dialog box.

Description and Use of This Dialog Box
Use this dialog box to add application icons to the HiJaak Browser Application bar.

Add Applications to the Application Bar as Follows:
1. Pull down the Setup menu and click on Application Bar. You will see the Application 

Bar dialog box.
2. Click on the Add button (Alt+a). You will see the Add Application dialog box.
3. Pull down the Drives drop down list an click on the drive that contains the application you

want to add (Alt+v, arrow, Enter).
4. In the Directories area, double-click on the subdirectory that contains the application 

you want to add (Alt+d, arrow, enter).
5. Click in the File Name area and type the name of the application you want to add to the 

HiJaak Browser Application bar (Alt+n).
6. Click on OK. You will see the Application Bar dialog box with the icon and path of the 

application you selected appearing at the top of the Applications list. 

For more information about the Application Bar dialog box, click on the following:
Application Bar



Change Icon
How to Find This Dialog Box
Click on the Change Icon button in the Application Bar dialog box to see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to change the icon that represents a particular application in the 
Application bar. By default, the icon used in the application's program group is used.

Change an Application Icon as Follows:
1. Pull down the Setup menu and click on Application Bar (Alt+s, a). You will see the 

Application Bar dialog box.
2. In the Applications list, click on the icon and path to the application whose icon you want

to change (Alt+p, arrow).
3. Click on the Change Icon button (Alt+i). You will see the Change Icon dialog box.
4. In the File Name field, type the full path to the icon that you want to use to replace the 

current one (Alt+n). If you don't know the full path, click on the Browse button to search 
for it (Alt+b).

5. In the Current Icon area, you will see all the icons available in the path you selected. 
Click on the icon you want to use (Alt +c, arrow).

6. Click on OK. You will see the Application Bar dialog box with the new icon you selected 
in the Applications list. For more information on the Application Bar dialog box, click on 
the following:
Application Bar



Confirmations
Select Confirmations from the Setup menu to see this dialog box.

Description and Use of This Dialog Box
When you select Delete, Move or Copy, HiJaak Browser displays a message allowing you to 
confirm that operation. This is a safeguard against accidentally deleting or replacing 
important files. If you do not want to see confirmation messages, you can turn them off 
using the Confirmations dialog box.

Set up Confirmations as Follows:
1. Pull down the Setup menu and click on Confirmations (Alt+s, c). You will see the 

Confirmations dialog box.
2. By default, all options are selected. This means that HiJaak Browser will display 

confirmation messages on the following operations:
File Delete (f)
Directory Delete (d)
Collection Delete (c)
Search Delete (s)
File Replace (r)
File Copy (o)
File Move (m)

Click on the check box beside those operations for which you don't want to receive a 
confirmation message.

3. Click on OK. 



Associate Application

How to Find This Dialog Box
Select Associate Application from the Setup menu, and you will see this dialog box.

Description and Use of This Dialog Box
This dialog box allows you to associate a file extension with an application. This allows you 
to open the file and start the application at the same time. If you associate an application 
and then update a thumbnail representing a file of the associated extension, the updated 
thumbnail will contain an icon of the application with which the file extension is associated.

Note: Do not confuse this command with HiJaak Browser's Associate Format 
command. The Associate Application command allows you to associate file 
extensions with applications, similar to Windows File Manager's Associate command. 
HiJaak Browser's Associate Format command associates format extensions with 
HiJaak Browser, or registers file extensions with File Manager. If you want to associate
the DOC extension with Microsoft Word, you should use the Associate Application 
command. If you want HiJaak Browser to open EPS files with an ART extension, use 
the Associate Format command.

Associate a File Extension with an Application as Follows:
1. Pull down the Setup menu and click on Associate Application (Alt+s, a). You will see 

the Associate Application dialog box.
2. Click in the Files with Extension field and type the file extension you want to associate 

(Alt+e).
3. In the Associate With list, click on the application you want to associate with the file 

(Alt+a, arrow). 
For example, suppose you want to associate the extension INI with Windows Notepad. In 
the Files with Extension field, type the following:
INI
In the Associate With list, click on Text File (notepad.exe).
If you don't see the application in the Associate With list, click on the Browse button 
(Alt+b). You will see the Browse dialog box. For more information on how to use this 
dialog box, click on the following:
Browse

4. Click on OK. 



Associate Format

How to Find This Command
This command is located in the Setup menu. Select Associate Format from the Setup 
menu and you will see the Format Extensions dialog box.

Description and Use of This Command
Use Within HiJaak Graphics Suite

The Format Extensions dialog box allows you to change which extensions HiJaak 
associates with a particular format. If, for example, all of your EPS files have the 
extension ART, you can use this feature to make HiJaak recognize ART extensions as EPS 
files. 

Use in Windows File Manager
In addition to the above, if you select the Register button, you can "associate" a file type 
with HiJaak PRO in the Windows File Manager. For example, you can configure HiJaak so 
that when you double-click on an ART file in File Manger, the file will open in HiJaak PRO. 
The Register option associates HiJaak PRO with File Manager's OLE database. 

Change or Add Format Extension Associations as Follows:
1. Pull down the Setup menu and click on Associate Format (Alt+s, f). You will see the 

Format Extensions dialog box.
2. In the Formats list, scroll to the file format you want to associate with a particular 

extension (Alt+f, arrow). In the above example, you would highlight EPS.
3. Click in the Extension area (Alt+e). Type the extension you want to associate with the 

highlighted format. In the above example, you would type ART. 
4. If you want to delete an association, click on the Delete button (Alt+d).
5. If you want to register the association with Windows File Manager, click on the Register 

button (Alt+r). You will see the Register dialog box.
If you select All Formats (Alt+a), each time you double-click on any HiJaak-supported file
in the Windows File Manager, the file will open in HiJaak. Click on OK or press Enter to 
return to the Format Extensions dialog box. 

6. If you have another association to add, click on Add (Alt+a), then repeat steps 2 and 3 for
each association you want to add. When you have no more associations to do, and you do
not want to register the association with File Manager, click on OK (Enter) to accept the 
association.    



Save Settings on Exit
How to Find This Command
This command appears under the HiJaak Browser Setup menu.

Description and Use of This Command
HiJaak Browser allows you to save the appearance of the Index window and the arrangement
of the thumbnail windows when you exit.

To save these settings, pull down the Setup menu and click on Save Settings on Exit 
(Alt+s, s). A check appears next to this menu item to indicate that it is selected.





Learning HiJaak Browser

For brief tutorials on using HiJaak Browser, click on one of the following topics:

Viewing Files
This lesson will teach you how to view files.

Working With Directories
This lesson will teach you how to create, move and delete an entire directory.

Adding Bitmaps to Empty Thumbnails
This lesson will teach you how to update thumbnails by adding bitmaps to empty thumbnail 
slides.

Getting Graphics Into Your Applications
This lesson will teach you how to add the PC Paintbrush icon to the HiJaak Browser Application 
bar, how to convert a file for use in PC Paintbrush, and how to use that file to launch PC 
Paintbrush and open the file.

Searching for Files
This lesson will teach you how to create a Search that finds all temp files on your hard drive, how 
to delete those temp files, and then how to save the Search for reuse.

Cataloging Your CD-ROM Clip Art
This lesson will teach you how to catalog clip art that is on your CD-ROMs and add files to your 
Index.



Viewing Files
Learning HiJaak Browser

This version of HiJaak Browser lets you view graphics files that are in BMP, PCX or WMF format. You can
also view files whose formats are associated with an application through Windows File Manager. This 
association means that the application recognizes the format as one of its native formats. For example, 
the format WRI is associated with Windows Write. In File Manager, if you double-click on a file with 
a .WRI extension, Windows Write will open. HiJaak Browser works the same way,    double-clicking on a 
thumbnail of a file with a .WRI extension cause HiJaak Browser to launch Windows Write and open the 
file.

Note: The full version of HiJaak Graphics Suite allows you to view graphics in 72 additional 
formats. 

To View a File
1.    In the Index Tree, double-click on the INSET folder.

The INSET directory opens, and its contents display in the thumbnail window in the right side of 
the HiJaak Browser Main screen.

2.    In the INSET thumbnail window, double-click on the TUTORIAL Directory thumbnail.
The TUTORIAL directory opens, and its contents replace the INSET directory in the thumbnail 
window. In this window, you will see a thumbnail of a flower with the caption LILY256.PCX 
beneath it.

3.    Double-click on the thumbnail of the flower with the caption LILY256.PCX.
The picture of the lily opens in a separate HiJaak Browser window. When you want to close this 
image, double-click on the Control bar located in the upper-left corner of the image.

To learn more about viewing files and thumbnail windows, click on one of the following:
How to View a File
How to Change the View of an Image
How to Change the View of a Thumbnail Window
How to View and Change Properties of a File



Working With Directories
Learning HiJaak Browser

HiJaak Browser works as a file manager, allowing you to create, copy, move and delete directories. In the 
following procedures you will learn how to create a directory, how to move that directory, and finally how 
to delete it.

 To Create a Directory
1. Click on the New button, located in the Button bar beneath the Main menu in the HiJaak 

Browser window.
You will see the New dialog box.

2. In the Type area, click on the Directory radio button.
In the Index Tree area of the dialog box, focus moves to the Directories area. HiJaak Browser 
allows you to create Searches and Collections, as well as Directories. 

3. In the Index Tree, double-click on the C:\ drive.
This selects the root of the C:\ drive. You will be creating a directory at the root level. To create a 
subdirectory of an existing directory, you would double-click on the existing directory's name.

4. Click in the Name field and type the following: TESTDIR
This is the name of your new Directory. When you create a Directory using HiJaak Browser, you 
must follow DOS naming rules: up to 8 characters with no spaces.

5. Click on OK.
The New dialog box closes and HiJaak Browser creates a Directory named TESTDIR. You should
now see a folder named TESTDIR beneath C:\ in the Index Tree area of the Main screen.

To Move a Directory
You can move a directory to a new drive or directory and all of its files and subdirectories will move with it.
1. In the Index Tree, double-click on the TESTDIR Directory that you just created.

The contents of the TESTDIR appear in the thumbnail window. Since this is an empty directory, 
the thumbnail window is empty with the exception of the GoBack arrow.

2. In the upper-left corner of the thumbnail window, double-click on the GoBack arrow. 
Double-clicking on the GoBack arrow moves you back one level in the Directory Tree. In this 
case, you will be in the root of the C: drive. You should see a yellow folder thumbnail representing
the TESTDIR in the thumbnail window. If you have many root directories on your hard drive, you 
may have to use the horizontal scroll bar at the bottom of the thumbnail window to see the 
TESTDIR thumbnail. 

3. Click on the TESTDIR thumbnail. 
This selects the entire TESTDIR Directory.

4. In the Index Tree, make sure you can see the INSET Directory. If you cannot, use the vertical 
scroll bar to the right of the Index Tree and scroll until you see it.

You will be moving the TESTDIR directory to the INSET directory; therefore, the INSET directory 
needs to be visible in the Index Tree. 

5. Click on the TESTDIR thumbnail and hold down the mouse button. Drag the thumbnail from the 
thumbnail window to the INSET Directory in the Index Tree. Release the mouse button.

You will see a Confirm File Move message, "Are you sure you want to move selected files to 
directory C:\INSET?" Click on Yes.
HiJaak Browser moves the entire Directory to the INSET folder. In the Index Tree, TESTDIR will 
appears as a subdirectory of INSET. In the following procedure, you will delete this directory.

HINT: To copy a directory, hold down the CTRL key as you drag and drop.



 To Delete a Directory
HiJaak Browser allows you to delete an entire directory, including all the subdirectories and files 
contained within the directory. You cannot un-delete a directory or file, so make sure you have carefully 
selected the files to delete.
1. In the Index Tree, double-click on the INSET Directory.
2. In the INSET Directory window, click on the TESTDIR thumbnail.

This selects the entire directory. 
4. Click on the Delete button. You will see a Confirm Delete message box. To delete the selected 

directory and any subdirectories and files located within that directory, click on the Yes To All 
button.

The Confirm Delete dialog box gives you the chance to change your mind about deleting files. 
You can even delete one file at a time by clicking on the Yes button. This allows you to check 
each file before deleting. Note, however, that if you choose not to delete even one file located in 
that directory, the directory will not be deleted.

To learn more about creating Directories, Searches or Collections, click on the following:
New

To learn more about moving files, Directories, Searches or Collections, click on the following:
Move

To learn more about deleting files, Directories, Searches or Collections, click on the following:
Delete



Getting Graphics Into Your Applications
Learning HiJaak Browser

This lesson will teach you how to add the PC Paintbrush icon to the HiJaak Browser Application bar, how 
to convert a file for use in PC Paintbrush, and the how to use that file to launch PC Paintbrush and open 
the file.

To Add the PC Paintbrush Icon to the Application Bar
The HiJaak Browser Application bar is located along the right side of the HiJaak Browser Main window. 
You can place any Windows application's icon on this bar. By placing an application's icon on the 
Application bar, you can launch that application directly from HiJaak Browser. You can search for a file 
and open it directly in the editing application. The following procedure assumes that you have installed 
Windows in C:\WINDOWS. If you have not installed here, replace C:\WINDOWS with your path to the 
WINDOWS directory.

1. In the Index Tree, double-click on C:\. 
The thumbnail window displays thumbnails of all directories and files in the root of the C: drive.

2. In the thumbnail window, double-click on the WINDOWS Directory thumbnail. 
The thumbnail window displays thumbnails of all subdirectories and files in the WINDOWS 
directory.

3. Scan the thumbnail window for the thumbnail with the caption PBRUSH.EXE. 
This thumbnail represents the PC Paintbrush program. 

4. Click on the thumbnail with the caption PBRUSH.EXE and hold down the mouse button. Drag 
the thumbnail to an empty spot on the Application bar, and release the mouse button to drop 
the icon onto the Application bar. Do not release the mouse button when the cursor is over 
another icon in the Application bar.

The PC Paintbrush icon appears in the Application bar.

To learn more about the Application bar, click on the following:
Application Bar

To Convert an Image from One Format to Another
PC Paintbrush can open images in BMP or PCX format, but it cannot open images in WMF format. Using 
HiJaak Browser, you can convert a graphics file from WMF format to PCX format so that PC Paintbrush 
can open it.

1. In the Index Tree, double-click on the INSET Directory node.
The INSET Directory opens and its contents display in the thumbnail window.

2. In the INSET thumbnail window, double-click on the SAMPLES Directory thumbnail.
The INSET\SAMPLES directory opens and its contents display in the thumbnail window.

3. In the INSET\SAMPLES thumbnail window, click on the thumbnail with the caption ISIJET.WMF.
The caption of the thumbnail becomes highlighted, indicating that it is selected. This file is in 
Windows Metafile WMF format and cannot be opened by PC Paintbrush. You need to convert it 
before you can open it in PC Paintbrush.

4. Pull down the File menu and click on Convert.
You will see the Convert To dialog box.

5. In the Directories area, double-click on C:\. Then, double-click on the INSET directory, and then 
double-click on the TUTORIAL subdirectory.

6. Click on the down arrow to the right of the List Files of Type drop-down list to pull down the list 
and view its contents. Click on PCX--PC Paintbrush.

In the File Name field, the name changes from ISIJET.WMF to ISIJET.PCX. 
7. Click on OK.



The Convert To dialog box closes and you will see the HiJaak Convert status bar. HiJaak Browser
converts the file C:\INSET\SAMPLES\ISIJET.WMF to C:\INSET\TUTORIAL\ISIJET.PCX. Note 
that the original file, ISIJET.WMF, remains unchanged in the SAMPLES directory. A new file, 
ISIJET.PCX, is created.

8. In the thumbnail window, double-click on the GoBack arrow to return to the INSET directory.
9. In the INSET Directory thumbnail window, double-click on the TUTORIAL Directory thumbnail.

The INSET\TUTORIAL Directory opens. You should see a thumbnail with the Caption ISIJET.PCX
in the thumbnail window. You can use this thumbnail to launch PC Paintbrush and open the file 
ISIJET.PCX. Notice that this thumbnail will have the words Needs Update on it; this means that 
the thumbnail needs to be updated to be added to the Index and have a bitmap appear in it. To 
learn how to add a bitmap to this thumbnail, click on the following:
Adding Bitmaps to Empty Thumbnails

To Launch PC Paintbrush
      Click on the thumbnail with the caption ISIJET.PCX and hold down the mouse button. Drag the

thumbnail to the PC Paintbrush icon in the Application bar and release the mouse button.
PC Paintbrush starts up and opens the file ISIJET.PCX. When you want to close PC Paintbrush, 
pull down the File menu and click on Exit.



Searching for Files
Learning HiJaak Browser

HiJaak Browser allows you to search for files on a number of criteria, including name, date, size, location, 
attributes and keywords. After HiJaak Browser finds the files that meet your criteria, it places thumbnails 
of the files in the HiJaak Browser thumbnail window. You can save the search criteria and open this 
Search at any time.

 To Search for Files
1. Click on the Search button in the Button Bar. 

You will see the Search dialog box.
2. Click in the File Name field and type the following: TMP.
3. Click on the arrow to the right of the Match drop-down list to pull down the list and view its 

contents. In the list, click on Ends With.
This command will find all files that end with the letters TMP. 

4. Click in the Location field and type C:\
This tells HiJaak Browser to search your entire hard drive. By default, HiJaak Browser searches 
through your entire Index for files that meet your criteria. Although you do not need to tell HiJaak 
Browser where to look, it's a good idea to select a location. Giving a location narrows the search 
so it's faster, and it lets HiJaak Browser search through all files, not just those that have been 
added to your Index (updated).

5. Click on OK.
You will see a Search message box telling you what directories HiJaak Browser is "scanning" and
how many files it has found. When the Search is complete the message box disappears, and you 
will see a Processing status box. When the status box disappears, the Search results appear in 
the thumbnail window. These results are called a Search window. This Search window contains 
thumbnails representing all the TMP files on your hard drive.
Since Temp files just take up valuable disk space, it's a good idea to delete them.

 To Delete TMP Files
1. To delete all the TMP files that were found, you can select all the thumbnails in the Search 

window. Hold down the Shift key and click on the first thumbnail in the window. Without 
releasing the Shift key, click on the last thumbnail in the window. Release the Shift key. 

This selects all the thumbnails. 
2. After the files are selected, click on the Delete button. You will see a Confirm File Delete 

message. Click on Yes to All.
You will see a Deleting status bar and then the thumbnails and the files will be deleted. Since 
applications are continually creating temp files, you may want to use this Search again. HiJaak 
Browser allows you to save the Search criteria.

To Save the Search for TMP Files
1.    Pull down the File menu and click on Save.

You will see the Save As dialog box.
2.    In the Type area, click on the Search radio button.

Whenever you perform a Search, you have the option of saving the results as a Search or as a 
Collection. You should save as a Search if you will want to run the Search again. You should save
as a Collection if you want to add or delete thumbnails in the group. Since searching for temp files
is something you could do daily, you are saving this as a Search.

3.    Click in the Name field and type the following: Temp Files
The Search will be named Temp Files. You can use up to 256 characters, including spaces, to 
name your Searches.



4.    Click on OK.
HiJaak Browser saves the Search as Temp Files. When you want to rerun the Search, double-
click on the Temp Files folder beneath the Saved Searches branch in the Index Tree. Then, click 
on the Update button.

To learn more about searching, click on the following:
How to Search for Files

To learn more about deleting files, Directories, Collections or Searches, click on the following:
Delete

To learn more about saving Collections and Searches, click on the following:
Save As



Adding Bitmaps to Empty Thumbnails
Learning HiJaak Browser

To add bitmaps to empty thumbnails, you add those files to the Index. Select the thumbnails that you want
to add to the Index and click on the Update button. The selected thumbnails are added to the Index and 
bitmaps appear in their thumbnails. If a thumbnail represents a supported graphics file, then a bitmap of 
that graphic appears in the thumbnail. If a thumbnail represents an application or a file that's associated 
with an application, the application's icon appears in the thumbnail.



Cataloging Your CD-ROM Clip Art
Learning HiJaak Browser

To use this procedure, you must have a CD-ROM with clip art on it. The full version of HiJaak Graphics 
Suite can catalog clip art in most graphics formats; however, this limited version can only catalog clip art 
in Windows Metafile *.WMF format. 

1. Put your clip art CD-ROM in your CD-ROM drive.
2. In the Index Tree, double-click on the Directories node.

The thumbnail window shows all the available drives on your system.
3. In the Directory window, click on the folder thumbnail that represents your CD-ROM drive.

The caption at the bottom of the thumbnail becomes highlighted, indicating that it is selected.
4. Click on the Update button in the button bar. You will see the Volume Label dialog box.

Before HiJaak Browser can catalog any removable media, it must have a volume label, or name 
for that particular media. The volume label allows HiJaak Browser to differentiate one disk or CD-
ROM from another.

5. In the Volume Label field, type a name for your clip art CD-ROM and click on OK.
This name will be used in the In Index section of the Index Tree at all times and in the Directories 
area of the Index Tree when the CD-ROM is in the drive.

6. You will see an Updating status bar, indicating that HiJaak Browser is cataloging your CD-ROM. 
When this box disappears, HiJaak Browser has completed cataloging your clip art.

When HiJaak Browser updates the Index, it catalogs file name, date, size, type and attributes of 
files, and adds that information to the Index. If the files contain text, HiJaak Browser also extracts 
the text, which you can later use in keyword searches.

To learn more, click on the following:
H  ow to Update the Index  
How to View and Change Properties of a File




